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Chapter 1
Getting Started

A Quick Start to the Oasys-RTL Tool guides you through the Oasys-RTL design flow. Together

with sample scripts and design data, it is a hands-on introduction to performing the basic
functions of the Oasys-RTL tool.

This module covers the following topics:

Oasys-RTL Flow

General Prerequisites

Setting up the Quick Start ExampleData.......... ..o iiiiiiiiiiiiiennns 11

Oasys-RTL Flow

The Oasys-RTL tool provides an integrated flow for synthesizing a gate-level netlist from a
behavioral RTL description.

Figure 1-1 shows the steps of this flow.
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Getting Started
Oasys-RTL Flow

Figure 1-1. Oasys-RTL Physical Synthesis Flow
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The chapters in this quick start guide show different aspects of this flow through examples.

Related Topics
Design Synthesis
Design Analysis
RTL Floorplanning

10

A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1

Note - Viewing PDF files within a web browser causes some links not to function. Use HTML for full navigation.



Getting Started
General Prerequisites

General Prerequisites

Ensure that your environment meets certain requirements before running the procedures in this
document.

You need the following:

e Sufficient storage space for running the design.

Setting up the Quick Start Example Data

The Quick Start provides a companion demo design example that you can use to quickly learn
the Oasys-RTL flow. All the steps in the Quick Start are based on this design data.

Prerequisites

e The oasys rtl_gs_ekit.tg= file containing both this document and the design data. This
file is located in the docs directory of the Oasys-RTL software tree. For example,
$0ASYS HOME/doc/oasys rtl_qs_ekit.tg=.

e Sufficient storage space for the design data and generated files. The recommended disk
space 1s at least 800 MB for the design archive and generated files from the Oasys-RTL
Tuns.

Procedure
1. Change to the directory from which you will run the examples.
2. Unpack the oasys_rtl gs_ekit.tgz file:
tar -xzvf oasys _rtl gs_ekit.tgz
3. Change directory to oasys rtl_gs_ekit:
cd oasys_rtl _gs_ekit
This directory contains the following:
e cleanup.sh — Utility script for removing output files, if any, from previous runs.
e constraints — SDC constraints file.

e demo_chip rtl — Contains the RTL files for the demo chip. This directory also
includes the demo_chip.odb file which contains the optimized design from Chapter
2 (in case you can not download the OpenCore source files).

e docs — Licensing information.

e [ibs — Oasys library file (ODB) containing Liberty and LEF info for standard cells
and macros/memories. Fastscan libraries for the Tessant DFT flow.

A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1 11
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Getting Started
Setting up the Quick Start Example Data

output — Log, command, and other output files generated during an Oasys-RTL

Sess1on.

scripts — Scripts used in the quick start examples for Oasys-RTL operation.

4. Download the various modules of the demo_chip design from the “download” link on
the following pages at the OpenCores website:

http://opencores.org/project,usb
Name: usb

Created: Sep 25, 2001

Updated: Jul 27, 2013
http://opencores.org/project,nova
Name: nova

Created: Apr 21, 2008

Updated: Jun 3, 2016
http://opencores.org/project,usb_phy
Name: usb_phy

Created: Sep 16, 2002

Updated: Jan 11, 2017
http://opencores.org/project,hpdme
Name: hpdme

Created: Oct 26, 2008

Updated: Aug 26, 2010
http://opencores.org/project,mips32rl
Name: mips32rl

Created: Oct 14, 2012

Updated: Apr 12, 2014

5. Unpack the contents of all downloaded files into the following directory:

/demo_chip_rtl/rtl/

Note

Note the r7// subdirectory above. If you unpack the design files into a different
directory, Oasys-RTL may report errors when loading the design.

12
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Getting Started
Setting up the Quick Start Example Data

There are a few wrapper files included in the oasys rfl gs ekit.tgz tar file under the
following directories:

/demo_chip rtl/rtl/demo_chip
/demo_chip rtl/rtl/lib_cells
/demo_chip_rtl/rtl/mem_wrapper

Results

You have now installed the design data. Before starting the remaining chapters, review the
items listed in General Prerequisites.

A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1 13
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Getting Started
Setting up the Quick Start Example Data
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Chapter 2
Design Synthesis

The Oasys-RTL tool 1s used for synthesizing the design, which includes steps such as loading
design inputs, synthesizing, optimizing, and exporting data.

Tip
9 If you want to skip the design setup procedure, you can bypass the first section.

Invoking the Oasys-RTL Tool and Preparing the Design for Synthesis ............ 15
Synthesizing and Optimizing the Design..........cciitiiiiiiiiiiiiiennnnnnns 16
EXDPOTHInG tHe DIeSIII . o oun o s icesone e &mmes s s 6w 5ue e o s e e smeeme 19

Invoking the Oasys-RTL Tool and Preparing
the Design for Synthesis

Load design data into the Oasys-RTL tool before running synthesis.

The synthesis and optimization scripts are located in the scripts directory. The init_design.tcl
file sets up script variables and file paths and is called from within the / read design.tcl script.
The 1 read design.tcl script reads the design data into the Oasys-RTL tool.

Prerequisites

e To enable Tessent integration with the e-kit, set the “dft flow” variable to “Tessent” and
set the “tessent build” variable to the full path for the Tessent executable.

Procedure

1. Make sure that you are in the directory where you extracted the demo data. You should
see the following sub-directories:

e constraints

e demo chip rtl

e docs
e libs
e output
e scripts
A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1 15
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Design Synthesis
Synthesizing and Optimizing the Design

2. Enter the following command to invoke the Oasys-RTL tool:

$OASYS HOME/bin/oasys -log output/logs/synth.log

You are presented with an Oasys-RTL shell:

[oasys-RTL] $

3. For interactive execution, review and enter each command from the scripts/
1 read design.tcl file on the command line. Or for batch execution, source the entire
Tcl file with the following command:

source scripts/1_read_design.tcl
This script file contains all of the commands to load the input design data into the tool.

The tool issues this message when it completes:

4. Keep the session open and proceed to the next step.

Results

The design files are loaded into the Oasys-RTL tool. The design optimization settings are set,
and the tool 1s now ready to perform synthesis on the example design.

Related Topics
Synthesizing and Optimizing the Design

Synthesizing and Optimizing the Design

After you have loaded the design inputs and specified the relevant settings, synthesize and
optimize the example design.

Procedure

1. If you are continuing with the previous session and the Oasys-RTL tool is still running,
go to the next step. If you have not invoked the Oasys-RTL tool, enter the following
command:

$OASYS HOME/bin/oasys -log output/logs/synth.log

2. The commands to synthesize the design are in the scripts/2 synthesize optimize.tcl file.
You can enter each command from the file or enter the entire Tc¢l file with the following
command:

source scripts/2_synthesize_optimize.tcl

This step can take 15-25 minutes, depending on the characteristics of the machine used.

16 A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1
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Design Synthesis
Synthesizing and Optimizing the Design

NOTE: If you did not download the RTL source from the Open Cores site, this script
will load a previously optimized design (demo chip rtl/demo chip.odb). This version

of the design also contains scan chains. Using this ODB file will allow you to complete
the steps in the tutorial but you will not be able to view or cross-probe to the RTL

source.

3. While the tool is running, you can review the contents of the script scripts/
2 synthesize_optimize.tcl and the output messages in the log file. Take note of the
Oasys-RTL flow commands used to perform synthesis, and search on the items listed in

Table 2-1.
Table 2-1. Search Strings to Review Progress of Synthesis, Optimization, and
DFT
Search String Description Action

“config_shell -echo true”

Configures the shell to echo
or log the commands. The
config_shell command sets
up different command shell
preferences.

Confirm the setting.

“config_tolerance”

Controls the severity of RTL
parser and elaboration errors
allowed for the read verilog,
read vhdl, and synthesize
commands.

Check the messages after
reading the RTL.

“synthesize
-module demo_chip

-map _to scan -gate clock”

Performs elaboration and
mapping of the specified top
module to the technology
library.

The -map to scan option
directs synthesis to map the
flops to scan flip-flops. If it
1s not specified, synthesize
will not use scan flip-flops
for registers.

The -gate clock option
performs clock gating on
enable flops.

Review the progress of
synthesis (design mapping).

“report_design metrics”

Display design related
information.

Review the values for Total
Instances, Blackboxes, Total
Number of Buffers and
Inverters, Area, and
Utilization.

Note - Viewing PDF files within a web browser causes some
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Design Synthesis
Synthesizing and Optimizing the Design

Table 2-1. Search Strings to Review Progress of Synthesis, Optimization, and

DFT (cont.)
Search String Description Action
“optimize -virtual” Performs virtual If timing is not met after

optimization that provides a | virtual optimization, identify
first check of feasibility to and fix the bottlenecks in the
close timing prior to full RTL or constraints before re-
optimization in the physical | running synthesis.

context. Running a regular
optimization after a virtual
optimization 1s
recommended only if timing
1s met in virtual placement.

Review the successive
occurrences of optimization
messages. Check messages
for area, timing, and
execution time information.

“optimize -place” Starts placement Check report timing before
optimization that optimizes | “optimize -place” and review
based on floorplan and the successive occurrences
physical placement. of timing-driven placement

messages.

“optimize” Starts optimization that Review worst negative slack
attempts to fix all timing (WNS) for timing
violations in the physical optimization. Also observe
context of the design. The total congestion, slack, and
result 1s a globally placed average percentage of

design that 1s optimized for | overflow.
timing, area, congestion, and
power.

“report_timing” Reports timing and path Notice slack before and after
groups after optimizations. | optimization for qualitative
analysis. Review the same
items after scan chain
connections.

“report_path groups”

4. Close the 2 synthesize optimize.tcl file. When the run is complete, the following
message 1s printed to the shell window:

5. If you want to insert scan chains into the design using Oasys or Tessent, you can source
one of the following scripts: This step may take approximately 10 minutes.

source ./scripts/oasys dft.tcl
source ./scripts/oasys tessent dft.tcl

6. Keep the session open and proceed to the next step.

18
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Design Synthesis
Exporting the Design

Results

The flow script executed in this procedure synthesizes and optimizes the demo design. The tool
saves the post-optimized design in the native Oasys-RTL database format (.odb) in the
<oasys_rtl_qs_ekit>/output/odb directory.

Related Topics
Exporting the Design

Exporting the Design

Export your synthesized design to different formats used by other tools.

Procedure

1. The commands to export the design are in the scripts/3_export design.tcl file. You can
enter each command from the file or enter the entire Tcl file with the following
command:

source scripts/3_export_design.tcl

This script writes out the synthesized Verilog, ODB, DEF, SDC, and DFT files from the
Oasys-RTL tool.

The script echoes the following message to the shell when it completes:

2. At the command line prompt, type:
exit
3. Proceed to Chapter 3, “Design Analysis”.
Results

The design is optimized. Output files for place-and-route hand-off are generated and saved
under the <oasys rtl_gs_ekit>/output/ directory as follows:

e Synthesized Verilog — demo_chip.oasys _final.v
e SDC — demo_chip.oasys_final. sdc

e DEF — demo_chip.def

e ODB — odb/demo_chip.oasys_final odb

e CTL — demo_chip.ctl

e STIL — demo_chip.stil

A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1 19
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Design Synthesis
Exporting the Design

If you downloaded the RTL source from the Open Cores site, the script writes a design ODB
file at the end of each major RTL synthesis stages to the <oasys rtl gs_ekit>/output/odb
directory as follows:

e Post-synthesis — demo_chip.syn.odb
e Post-Virtual Optimized— demo_chip.virtual opt.odb
e Post-Placement Optimized— demo_chip.placed opt.odb
Related Topics
Synthesizing and Optimizing the Design

20 A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1
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Chapter 3
Design Analysis

The Oasys-RTL graphical user interface can be used to view and analyze a synthesized design.

Mouse Operations . ......cuviieiiierssosenscssssesssssnsssnssssssssnasnns 21
Usingthe Qasys-RTL GUI ... ..ottt iiiiiiiiiiiitiitteenrssnosssnsssnannns 22
Analyzing Timing. .. ....oii ittt ittt iitiiitetntrsenessnosssnsssnannns 30
Analyzing Congestion .........cciiitiiieiineeenorenssssnsssnssssssssnannns 34
Analyzing Power ......c.ittiiiiiiiiiiiiieineeenoeenssssnsssnssssssssnannns 40
Analyzing Design for Test (DFT) . .....cviitiiiiiiiiiiiiiiiirnnerssnnsonnnnns 42

Mouse Operations

The mouse operations available in the Oasys-RTL GUI change depending on the current view.
In the Physical view and other tabs, the mouse buttons function as follows:
e Left-click — Selects an object; a click-and-drag zooms to the rectangular area drawn.
e Right-click — Opens a context-sensitive options menu.

¢ Keyboard Shortcuts — You can also use the keyboard shortcuts listed in Table 3-1.
Table 3-1. Keyboard Shortcuts for Navigating

Key press Action
Ctrl-plus (Ctrl-Shift-=) Zoom in
Ctrl-hyphen Zoom out
Ctrl-0 Zoom fit
Ctrl-1 Zoom selected
A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1 21
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Design Analysis
Using the Oasys-RTL GUI

In the Netlist view, clicking and dragging the left mouse button gives you different navigation
options, depending on the direction that you drag the mouse:

e go up — Pops the netlist view to the parent of the current hierarchy.
e zoom -0.5 — Zooms out by half of the current area.
e zoom — Selects an area to enlarge to fit the current window.

e zoom fit — Fits the current schematic into the window.

Using the Oasys-RTL GUI

Launch the GUI, load a previously generated Oasys-RTL database (<oasys_rtl_gs_ekit>/
output/odb/demo_chip.oasys_final.odb), and navigate the design.

Procedure
1. Enter the following command to invoke the Oasys-RTL GUI:

$OASYS HOME/bin/oasys -gui -log output/logs/analysis.log

Tip
o Use the start_gui command if you are already in an Oasys-RTL shell.

2. Open the synthesized and optimized Oasys-RTL database that you generated in Chapter
2, “Design Synthesis”, by sourcing the following script at the Oasys-RTL command
prompt:

source scripts/open_database.tcl

The current status of the loading process is reported to the Oasys-RTL shell view. At the
end of the script, Oasys reports the worst slack paths in the design.

When the database is completely loaded, the source netlist view of the top module is in
the center of the main window. Instances that belong to the top module are in the left
pane.

22 A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1



Design Analysis
Using the Oasys-RTL GUI

Note
If you did not download the RTL source from the Open Cores site, the

open_database.tcl script will load a previously optimized design (demo chip rtl/
demo chip.odb).

Oasys may report an error because the Source window can not find a hard-coded path to
the RTL source in the ODB file. As a result, you will not be able to view or cross-probe
to the RTL source but this ODB file will allow you to complete the other steps in the
tutorial.

Figure 3-1. The Oasys-RTL GUI
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3. Click the Physical tab above the source netlist view to view the initial floorplan.
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Using the Oasys-RTL GUI
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Figure 3-2. Oasys-RTL Physical View
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The physical view shows the placement of macros and RTL partitions. The Oasys-RTL
tool starts with an empty DEF view with only the design pins placed. The tool performs
floorplanning by placing the pins, macros, and RTL partitions in an optimal manner.

RTL partitions are displayed in purple. Macros are displayed in blue.

— Note
The layout depicted in the screenshots may be different from what you see in the
tool.

4. Select the “nova0” instance in the Logical Hierarchy browser on the left of the GUI. All
child partitions that belong to the nova0 instance are highlighted:

Figure 3-3. Selected nova0 Instance
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{§f ddro ... FZ PADBID
{# ddro_... FZ PADBID
{§ ddro ... = PADBID
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5. Click the Source tab. If you downloaded the RTL source from the Open Cores site, the
Verilog module instantiation is also highlighted:

Figure 3-4. Source View of Selected nova0 Instance

Source
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.clk (mclk_novaO),

.clk_reg(smclk),

.reset_n (reset_n_i),

.per_dout (per_dout_novad),

.per_addr (per_addr),

.per_din (per_din[15:0]),

.per_en (per_en),

.per_we (per_we),
.BitStream_buffer input (BitStream_buffer_in

.BitStream ram ren(BitStream ram ren_0_ i)
— "[:d_ . — — — "

The Oasys-RTL GUI provides cross-highlighting between many different design scopes,
which enables you to quickly debug issues. By default, the Source tab is included in the
list of design views. You can also move it to a new pane within the GUI by right-
clicking on the Source tab and selecting the Dock Tab item. You can place a docked
pane back in the main pane by right-clicking on the tab and selecting Tabify Tab.

In the Logical Hierarchy browser, select the nova0 > nova > reconstruction > sum
RTL partition and click the Physical tab.
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Figure 3-5. Selected sum Instance
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7. To show or hide fly lines, right-click in the physical view and choose Fly Lines > Show
Fly Lines or Fly Lines > Hide Fly Lines. The fly lines show all objects that share
connectivity with the highlighted instance.

Sh

Figure 3-. ow Fly Lines

|

A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1 27



Design Analysis
Using the Oasys-RTL GUI

10.

11.

You can also see flylines by selecting an instance and clicking on the Show Fly Lines
icon in the GUI. This icon also provides a drop-down menu that allows you to control
which destination objects (eg. ports, partitions) are included when generating the fly
lines.

Tip
9 You can also create flylines by clicking the middle mouse button on any instance.

Hide fly lines by right-clicking anywhere in the physical view and choosing Fly
Lines > Hide Fly Lines.

Left-click anywhere outside of the core area in the physical view to unselect all
highlighted instances. This returns the hierarchy selection to the top module.

Click the dropdown arrow next to the Normal View icon ( QD )

Figure 3-7. Physical Views

= T - M ]
B - 5~ e - AR @ -3 -

tist  Timing Points | Timin /1] Normal View
l{ Hierarchical View

= Power Domain View

4 Criticality View
% Leakage Power View
§¥ Threshold Voltage Group View

AR Dynamic Power View

More View Options...

The expanded View menu allows you to control the properties that are currently
displayed in the Physical tab.

The Normal View selection returns the physical view to the default setting.

Enable the Hierarchical view (h‘ ) from the View list.
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Figure 3-8. Hierarchical View

12. While the hierarchy view is active, select an instance from the Logical Hierarchy
browser and note that each instance hierarchy has a unique color.

Viewing the placement of the RTL instances in hierarchical view is useful to help
understand how the design data flow is dependent on the physical placement.

13. (optional) If you plan to continue with the next procedure, do not exit from the design
session.
Tip
You can close the Oasys-RTL GUI by typing stop gui at the command prompt or
using the Ctrl-. (Ctrl-period) keyboard shortcut.

Related Topics
Analyzing Timing
Analyzing Congestion
Analyzing Power
Analyzing Design for Test (DFT)
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Analyzing Timing

View timing issues in the example design.

Procedure

1. If not already running, invoke the Oasys-RTL GUI and source the scripts/

open_database.tcl script to load the demo chip design ODB databases.

To generate a report of the longest timing paths, type report_timing at the command
prompt.

The report indicates various details of a path by suffixing symbols to the end of the
library cell on the path. The following symbols are used to indicate the timing attributes:

* — An output has been virtually buffered for timing.

e #— An output, which 1s typically a register, has been upsized for loading.

e DU — A library cell has the “dont_use” property set to true.

e DT — A cell has the “dont_touch” property set to true.

e retime borrow — A state cell has a retime constraint and timing was borrowed.

The following example shows an instance with a virtual buffer delay (denoted with an *)
within a timing path:

b0/sreg[2] /CK->Q SDFFR X1 LVT#* rr 75.9 75.9 75.9 0.0 0.0 2.7 33.1 4
483, 815 /PD TOP (0.85)

If the design currently yields no negative slack paths, you can reduce the clock period
slightly to produce some timing violations to analyze in the following subsection of the
tutorial.

To reduce the clock period

a. Open the SDC constraint file at constraints/demo_chip_func.sdc
b. Change the clock_period variable from 100 to 99.5.

c. Save the changed SDC constraint file.

d. Source the SDC file in Oasys to update the clock constraints in the design:
source constraints/demo_chip_func.sdc
You can verify the clock periods used for timing analysis using the report clocks

command.

Click the Physical tab and choose Criticality View (£ ) from the View dropdown list
to visualize timing violations across the design.
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Figure 3-9. Criticality View
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This view shows the instances with timing violations within the placed hierarchy. It can
provide a high-level perspective of the violations before you analyze the timing reports
or make design modifications.

Ti
If 011% part of the design was highlighted, you are only viewing the criticality for
selected instances. Left-click outside of the core area in the Physical View to return
the selection to the top level, click the Normal View button, and then choose the
Criticality View again to highlight the entire design.

5. Click the Timing Points tab. A histogram of the timing slack is displayed. To provide a
better representation of the number of endpoints that were close to violating timing (eg.
negative slack), the maximum value in the histogram (To:) was changed from the
default value to 1000ps.
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Figure 3-10. Timing Points Tab

Netlist | Timing Points | TimingPath = SDC = Physical Power = UPF  Message Sot °
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Click the Endpoints List tab (within the Timing Points tab) to view a table of slack and
endpoints.

Select the first value at the top of the table.

Note
D The paths and slack values in the following figures may not match your results.
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Figure 3-11. Endpoint List

Netlist | Timing Points | Timing Path I SDC  Physical ‘ Power UPF | Message ‘ Source |

Physical hierarchy: ‘demo_chip (top) v ‘ D
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slack ‘endpoint from clock to clock
-369.4 nova0_ddr0/ddrio/iddr_dq_iddr0_Q1_reg/Sli vsysclk sysclk
-31.8 SO _3 usbclk vsysclk

nova0/nova/BitStream_controller/mvy mbAddrC RF ram reg[0][7]/D
-11.2 novaO/nova/BitStream_controller/mvy_mbAddrC_RF_ram_reg[1][7]/D sysclk sysclk
-11.2 novaO/nova/BitStream_controller/mvy_mbAddrC_RF_ram_reg[2][7]/D sysclk sysclk
-11.2 nova0/nova/BitStream_controller/mvy_mbAddrC_RF_ram_reg[3][7]/D sysclk sysclk

8. Click the Timing Path tab.

Another Timing Path tab appears below. This tab displays the timing start and end
points for the path you selected in the previous step.

Figure 3-12. Timing Path
l Netlist ‘ Timing Points | Timing Path | SDC [ Physical ‘ Power | UPF { Message  Source

From/Through: ‘
To: ‘ nova0/nova/BitStream_controller/mvy_mbAddrC_RF_ram_reg[0][7]/D
Timing Mode:
Timing Path | Timing Info
Net Arc Arrival
Pin/Arc ~ Slew (ps) Delay (ps) Delay (ps) Time (ps) Edge
(DT) i_MAIN_PLL/PLLOUT 0.0 0.0 r
» @ 1_5/pll_clk_o->01 0.0 0.0 0.0 0.0 :
» E nova0/clk 0.0 0.0
Slack -11.2
Shift {sysclk->sysclk} 2287.5
mvy_mbAddrC_RF_ram_reg[0][7]/CK->D 0.0 0.0 -337.0 -337.0 r
» i_5/pll_ clk o-=01 0.0 0.0 0.0 0.0 I
(DT) I_MAIN_PLL/PLLOUT 0.0 0.0
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9. Click the Timing Info tab. This view displays the originating and receiving elements of
the timing path in addition to timing metrics such as the clock period, uncertainty,
latency, and setup time.

10. Click the Timing Path tab and click the Open to Rtl button at the bottom of the
window. This feature expands the selected timing path to the RTL level of hierarchy
without showing low-level mapped technology cells in the timing path.

Some common timing symbols that appear in the Timing Path window are described in

Table 3-2.
Table 3-2. GUI Timing Symbols
Symbol Identifier Description
B RTL partition RTL partition in the design. These
symbols indicate highly interconnected
blocks that are placed in close proximity.
] <register name> Starting point of the timing path.
3 Mux symbol with notch at inputs Datapath in the timing report.
D Mux symbol Mux implementation in the timing path.
O AND symbol Combinational logic in the timing path.
@ always always_<name> RTL “always” block.

11. Explore the cross-highlighting features of RTL components in the Timing Path tab by
clicking on elements in the Timing Path and viewing the element in the Physical
window. If you downloaded the RTL source for the lower level blocks, you can also
view the RTL code for the element in the Timing Path in the Source window.

12. (optional) If you plan to continue with the next procedure, do not exit from the design
session.

Related Topics
Using the Oasys-RTL GUI
Analyzing Congestion
Analyzing Power
Analyzing Design for Test (DFT)

Analyzing Congestion

View congestion issues in the example design.
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Procedure

1.

If not already running, invoke the Oasys-RTL GUI and source the scripts/
open_database.tcl script to load the synthesized design.

2. Select the Physical tab and press Ctrl + 0 to fit the core area to the current view.
3. Left-click outside of the core area to deselect any selected instances.
4. Right-click outside of the core area and select View > Normal View to enable Normal
View.
5. Select the Routing Congestion Map icon ( # ~) in the main menu.
This plots a congestion map over the physical design (Figure 3-13).
— Note
By default, the congestion map displays in “grid view”. To disable this (as shown in
figure), select the dropdown list arrow beside the Routing Congestion Map icon
and select Congestion View Options. Then in the Congestion Set dialog box, uncheck
Grid View and click Apply.
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Figure 3-13. Routing Congestion View
R Bx-DO - v 2 .:.aD m B R
g Points =~ Timing Path | SDC | Physical [

Congestion View Options...

6. Select View > Legends from the main menu. The Congestion tab that opens on the right
side of the main window defines how the colors map to the congestion overflow
percentage.
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Figure 3-14. Congestion View Legend
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8. Left-click and drag a box to zoom to a congestion hotspot in the physical view.
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Figure 3-15. Zoom in on Hotspot
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9. Left-click the instance that represents the source of the congestion hotspot. Observe the
corresponding highlight in the Logical Hierarchy browser.
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Figure 3-16. Highlighted Instance After Clicking Congestion Hotspot
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10. (optional) If you downloaded the OpenCore source files, click the Source tab.

The RTL code that generates this congested area is highlighted in the Source view. This
1s used to understand the source design components that cause congestion issues in the
Physical view.

11. (optional) If you plan to continue with the next procedure, do not exit from the design
session.
Related Topics
Using the Oasys-RTL GUI
Analyzing Timing
Analyzing Power
Analyzing Design for Test (DFT)
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Analyzing Power

View the physical power properties of the design.

Procedure

L.

1.

If not already running, invoke the Oasys-RTL GUI and source the scripts/
open_database.tcl script to load the synthesized design.

Select the Physical tab and use Ctrl+0 to fit the core area to the current window.

Click the Routing Congestion Map icon to unselect congestion view (if it 1s still
showing from the last task).

Left-click outside of the core area to deselect any selected instances.

Select View > Legends from the main menu. The Domain tab that opens on the right
side of the main window defines how the colors map to the specified power domains in
the design.

Enter the following command at the Oasys-RTL command prompt:
report_leakage

Note that the Macros row in the leakage report consumes significantly more static power
than the leaf cells (Cells row):

Report Leakage Efficiency:

——————————————————————— e e S ot e S R 1 i e R
|# cells |Leakage (uW) |default_vth %#cells
——————————————————————— L e .
Design Name (Top Module) |demo_chip| (Total) 9274.380]|
Macros | 50| 6218.599] 100.000
Pads | 300 5.926| 100.000
Cells | 301317| 3049.856| 100.000

Select the Leakage Power View (:ﬁ_ﬂf) from the View dropdown list.
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Figure 3-17. Leakage Power View
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The leakage map plotted on the design visualizes the report, where the macro blocks
dissipate higher amounts of static power than the placed cell area.

The Leakage tab of the Legends window maps the colors to the leakage power per
square micron.

8. Enter the following command at the Oasys-RTL command prompt:
report_power

This itemizes the dynamic and leakage power for all design blocks. This command takes
some time to execute.

9. Select the Dynamic Power View ( m) from the View dropdown list.

The Dynamic tab of the Legends window maps the colors to the dynamic power per
square micron.

10. Click one of the red instances in the core area in the Physical view.
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Figure 3-18. Dynamic Power View
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Note that this instance belongs to the noval block, which has the highest reported
switching power in the report.

11. Click the Source tab and note that instance is also highlighted in the RTL code.

12. (optional) If you plan to continue with the next procedure, do not exit from the design
session.

Related Topics
Using the Oasys-RTL GUI

Analyzing Congestion
Analyzing Timing
Analyzing Design for Test (DFT)

Analyzing Design for Test (DFT)

View scan chains and debug DFT issues in the example design.
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Procedure

1. If you are not continuing from the previous session, invoke the Oasys-RTL GUI and
source the scripts/open_database.tcl script to load the synthesized design.

2. Ifyou did not insert Scan Chains into the design yet, you run either of the following
scripts. For this design, scan insertion should take approxiately10 minutes to complete.

(Using Oasys DFT) : source scripts/oasys_dft.tcl
(Using Tessent) : source scripts/oasys_tessent dft.tcl

3. Select the Physical tab, and select Normal View from the View dropdown list.

4. Click the Scan Chains icon ( %) in the main menu ().Figure 3-19

Figure 3-19. Scan Chain View
Netlist = Timing Points = Timing Path = SDC | Physical | Power  «|» | Legends

color name
scanChain_1
B scanChain_2
scanChain_3

Each scan chain path is drawn with a unique color.

5. Select Analyze > Test > Report Scan Chains from the main menu.
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This opens the Scan Chain Report dialog box.
6. Click scanChain 2. This highlights only the selected scan chain (Figure 3-20).

Figure 3-20. scanChain2 Highlighted
Netlist  Timing Points = Timing Path = SDC | Physical = Power Message  Source

Scan Chain Report

Chain Scaninstance Length TestClock ClockEdge
scanChain_1 28956 29080 sysclk_byp rise
scanChain_2 28954 29078 sclk_byp rise
scanChain_3 1223 1334 sysclk_byp mixed

7. Close the Scan Chain Report window.

8. Run the following set of commands at the command line prompt.

— Note
These command are necessary because the ODB previously loaded by the scripts/
open_database.tcl script already had DFT violations fixed.

# <dft> is oasysdft or tessent

delete_design

read_db output/odb/demo_chip.<dft>pre_fix.odb
check_dft

9. Click the Netlist tab.

10. Choose Analyze > Test > Report Dft Violations from the main menu.
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This opens the Dft Violation Report dialog box (Figure 3-21).

11. Select the first violation in the report. The machine-generated instance names may be
different in your design.

Figure 3-21. DFT Violations
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Power

The Netlist tab displays the DFT violation in the context of the system schematic. You
may need to zoom in to see the problem. In this case, the mux blocks the clock signal
from propagating to the USB PHY.

To address this 1ssue, you could fix the RTL code or use the autofix feature within the
tool. The Oasys-RTL tool has the capability to fix the clock and DFT DRC violations
with the fix_dft_violations command. This command fixes violations by inserting test
logic so that, in scan mode, the corresponding signals propagate from primary inputs and
bypass the internally generated signal that is uncontrollable.

12. To use the autofix feature to address the DFT violations in the design, issue this

command:

fix_dft_violations -type all -test_clock sysclk_byp -test_control scan_mode

This command inserts logic into your design to address the DFT DRC violations.

A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1

45
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Analyzing Design for Test (DFT)

13. Close the Oasys-RTL tool and continue to Chapter 4, “RTL Floorplanning™.

Related Topics
Using the Oasys-RTL GUI
Analyzing Timing
Analyzing Power
Analyzing Congestion
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Chapter 4
RTL Floorplanning

The Oasys-RTL graphical user interface can be used to modify a floorplan.

Generating an Initial Floorplan . .. ... ..ottt iiiicennnannns 47
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Generating an Initial Floorplan

To generate an initial floorplan, set a new aspect ratio, change the core utilization, or both.

The default core area has a square aspect ratio. The aspect ratio is defined as the height to width
ratio. The default core utilization is 60%. To minimize or remove potential congestion hot spots
(as seen in the Congestion Map), modify these values to reach an optimum result.

Prerequisites
e A generated design database (odb).

Procedure
1. Enter the following command to invoke the Oasys-RTL GUI:
$OASYS HOME/bin/oasys -gui -log output/logs/floorplan.log

2. Open the synthesized and optimized Oasys-RTL database, generated in Chapter 2,
“Design Synthesis”, by entering the following command at the Oasys-RTL command
prompt at the bottom of the GUI window:

read_db output/odb/demo_chip.oasys_final.odb
3. Atthe Oasys-RTL prompt in the GUI, enter the following command:
delete_physical -all
This completely removes the placed physical design.
4. Select the Physical tab. Notice that the view is empty.

5. From the menu, select Flow > Optimize.
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RTL Floorplanning
Generating an Initial Floorplan

This opens the Optimize dialog box.

o () optimize () ¥ & x
Critical Ratio [0.0
Options

Virtual % Place only|

[ ok ]| came

6. Select the Place only selection box and click OK.

The shell view shows the progress of the operation. At completion, the Physical view
shows the placed macros and RTL blocks.

Click the Routing Congestion Map icon to see possible congestion areas in the
placement (Figure 4-1).

— Note
By default, the congestion map displays in “grid view”. To disable this (as shown in

Figure 4-1 and Figure 4-3), select the dropdown list arrow beside the Routing
Congestion Map icon and select Congestion View Options. Then in the Congestion Set
dialog box, uncheck Grid View and click Apply.
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RTL Floorplanning
Generating an Initial Floorplan

Figure 4-1. Routing Congestion View With Hotspots

Notice the hot spots throughout the design. To minimize these, modify the aspect ratio
and core utilization.

8. Remove the physical data from the design. To do this, do one of the following:

e Enter “delete physical -all” in the Oasys-RTL prompt at the bottom of the GUIL.
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e From the menu, select Floorplan > Delete Physical and then select the Core and
Pre-Routes selection boxes. All other fields are already selected.

o () Delete Physical ) &) (& )
Chip
| Core % Pre-routes
- %] Macro . - % Pin
) Placed Placed
® All ® All
- 1% Region \ ¢ %] Blockage -
%) Reglon % Placement
% Fence
® Routl
% Guide e
% RTL Placement
[ ox ][ cume |

Click OK. This opens a dialog box asking for confirmation to delete all physical
information. Click Yes.

9. From the menu, select Floorplan > Edit Core Area.
This opens the Core Area Editing form.
10. Select Core Utilization And Aspect Ratio and set the following values:
e Utilization = 40

e Aspect Ratio (Height/Width) = 0.8
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Generating an Initial Floorplan

Select the Delete All Physical selection box and click OK.

o () Core Area Editing <@o6sal! () & (= ®
~ Core Mal#ﬂ -

Left Indent: [_o 000

Bottom Indent: [o.oc-o

Right Indent:  |0.000

5§ 5§ §

Top Indent: [o.ooo

-] Die Area-

Die Width:  [0.000 | um

Die Helght

|

I

Die Origin X: |0.000
- L

r

Die Origin Y: | 0.000 um

- [ Core Utilization And Aspect Ratio

Utilization: 40 %
Aot o i)

% Delete All Physical

[Lox ] [Lomes ]

In the Physical tab, a new bounding box using the modified design aspect ratio appears.
Notice that it is a rectangle.

11. To generate a new placement, select Flow > Optimize from the menu. In the Optimize
dialog box, select the Place only box and click OK.

At the end of the operation, a new physical view appears. Notice the rectangular shape
of the design and the more loosely placed blocks (Figure 4-2).
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Generating an Initial Floorplan

Figure 4-2. Modified Placement of the Design

12. Click the Routing Congestion Map icon to view the effect on the routing congestion
(Figure 4-3).
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Generating an Initial Floorplan

Figure 4-3. Routing Congestion View After Modified Placement

13. (optional) You can use commands available through the Arrange icon to perform minor
interactive refinements of the macro placement in the floorplan, such as abut, rotate, and

move commands (Figure 4-4).

Note
To revert your actions on any manual movement of the macros, you can use the

Undo and Redo buttons.
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Figure 4-4. Arrange, Undo, and Redo Commands

Arrange Icon

. -1 " =
Q oS- Hl- o R

Source | Netlis ), Bring to Front 'iming Path | SDC | Physical

Send to Back
Bring Forward

Send Backward

i~ Rotate

Pack

More Abut Options...

The following steps demonstrate some different ways you can arrange macros.
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a. Abut Macros Horizontally — Select two macros (for example, as shown in the
following figure), then click the Arrange icon and select Align > Abut Horizontal
Left.

The following figure shows the macros after they have been abutted with each other
horizontally to the left.

You can use the get attribute command to verify the movement of the macros and to
detect the shift in coordinates:

get_attribute -class cell [get_selection] origin
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The original position of the macros:

73.000000 5.000000 5.000000 5.000000

Updated position of the macros:

63.000000 5.000000 5.000000 5.000000

To abut macros horizontally right, click the Arrange icon and select Align > Abut
Horizontal Right.

b. Abut Macros Vertically — Select two macros (as shown in the following figure),
then click the Arrange icon and select Align > Abut Vertical Up.
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Generating an Initial Floorplan

The following figure shows the macros after they have been abutted with each other
vertically upward.

Use the get_attribute command to verify the movement of the macros:
get_attribute -class cell [get_selection] origin

Original position:
659.089966 502.399963 758.089966 64.399948

Updated position:

659.085022 502.399994 758.085022 74.400002

To abut macros vertically downward, click the Arrange icon and select
Align > Abut Vertical Down.

c. Abut Macros to a Specified Distance — Click the Arrange icon and select
Align > More Abut Options.
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The following dialog box appears:

o Abut Setup () (v) (a (X

Abut Distance 25.00

Apply ] Close

Enter a distance (in this case, 25u) and click the Apply button. As a result, when you
perform any of the abut operations, the tool will apply the specified distance. As an
example, consider the macros in the following figure:

Select the two macros, then click the Arrange icon and select Align > Abut
Horizontal Left.

As aresult, the macros are abutted with an intervening space of 25u. Check that the
specified distance has been used using the get attribute command:

get_attribute -class cell [get_selection] origin
Original position:

63.000000 5.000000 5.000000 5.000000
Updated position:

88.000000 5.000000 5.000000 5.000000
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Generating an Initial Floorplan

a. Align a Set Macros Relative to Each Other — Select two (or more) macros (as
shown in the following figure), then click the Arrange icon and select
Align > Align Left.

The following figure shows the macros after they have been aligned with the
leftmost macro:

Use the get_attribute command to verify the coordinates of the macros.
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Constraining a Floorplan with User-Defined Blockages and Regions

get_attribute -class cell [get_selection] origin
Original position:

21.365000 129.565002 5.000000 5.000000

Updated position:

5.000000 129.565002 5.000000 5.000000

14. (optional) If you plan to continue with the next procedure, do not exit from the design
session.
Related Topics
Constraining a Floorplan with User-Defined Blockages and Regions

Creating a Rectilinear Floorplan

Constraining a Floorplan with User-Defined
Blockages and Regions

To add physical constraints to the floorplan, one method is to draw fences and regions. Use
fences to confine hierarchical modules by keeping them out of a certain region. Use regions to
group blocks together in a designated area.

Physical constraints, called blockages, can be added to the floorplan to prevent placements of
cells in specific areas. You can use the create blockage command or the Create Blockage
selection in the GUI to create or modify blockages.

In the DEF layout, a TYPE can be specified for a REGION. By default, the create region
command assigns a TYPE of DEFAULT. All instances assigned to the region are placed inside
the region boundaries. Other cells can also be placed inside the region.

For a REGION TYPE of FENCE, all assigned instances must be exclusively placed inside the
region boundaries. No other instances are allowed inside the FENCE region.

For TYPE of GUIDE all instances should be placed inside the region; however, it is a
preference, not a hard constraint. Other constraints, such as the wire length and timing, can
override this preference.

Prerequisites
e A generated design database (odb).
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Constraining a Floorplan with User-Defined Blockages and Regions

Procedure

1.

e A

9.

If you are continuing from “Generating an Initial Floorplan™ on page 47, go to the next
step. Otherwise, do the following:

a. Invoke the Oasys-RTL GUI:
$OASYS HOME/bin/ocasys -gui -log output/logs/floorplan.log
b. Open the synthesized and optimized Oasys-RTL database generated in module 2:
read_db output/odb/demo_chip.oasys_final.odb
Delete the physical data by entering the following command at the Oasys-RTL prompt:
delete_physical -all

Open the Core Area Editing form by selecting Floorplan > Edit Core Area.

In the Core Area Editing form, select the Core Utilization and Aspect Ratio box and
enter the following values:

e Utilization = 40

e Aspect Ratio (Height/Width) = 0.8

e Delete all physical: enabled

Click OK to create a new floorplan outline for the design.
Click Yes if a confirmation dialog appears.

Select the Physical tab.

Click the arrow to the right of the create menu to expand the Create list.

2% Create Region

L

Select the Create Blockage ( % ) from the Create list. The cursor turns to a “+7,
enabling the drawing function.

10. Draw a rectangle in the upper right corner of the floorplan area.
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To draw a rectangle, click inside the floorplan area and drag the mouse to the upper right
corner of the floorplan outline.

»
4
g

62 A Quick Start to the Oasys-RTL™ Tool, v2022.2.R1



RTL Floorplanning
Constraining a Floorplan with User-Defined Blockages and Regions

— Note
By default the Oasys-RTL tool creates only hard blockages, but if you want to create

soft and partial blockages, right-click in the rectangle and select Properties. In the
Object Properties dialog box, modify the Blockage Type setting.

o () Object Properties < (?) () (»

| Blockage

blockage
b__1353

1005.5
721,26
650.2

Height 607.56

Blockage Type

o

11. Select Create Region ( EL% ) tool from the Create list.
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12. Similar to creating a blockage, create a region in the upper left corner of the floorplan
area.

Click and Drag

Notice the text in the upper-left corner of the region. This gives the current area
utilization for the region. Find the name of the region in the bottom-left corner.
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Constraining a Floorplan with User-Defined Blockages and Regions

13. Assignthei cpu sys block to the region (1 ») as follows:

a. Inthe Instance list, select the 1 _cpu sys block and right-click to open the pull-down
menu.

b. From the menu, select Assign to region. A list of regions appears; in this case there
1s only one region.

Figure 4-5. Assign to Region

nstance module L .

+ [:_J data_mer| Properties h_32_12

¥ t._l program _| Satbalor h 32 12 1 {
+- Il i_usbt | 1
+ B nova0 Clear Color rapper !
+ l:_J noval ddr0 [~ hpdme {
+ [_'__‘[ noval ddr [T hpdmc_ paramelerized... |
+- (] nova0_ddr2 [T hpdme__parameterizedi |
+- || nova0_ddr3 [T hpdmec_ parameterized0 |
+ [_‘__1 nova1l [~ nova_wrapper
+ Q E

c. Selecttheregion “ r »”. Notice that the utilization percentage changes (util=%).

14. To complete the placement, select Flow > Optimize and select the Place only box in the
Optimize dialog box. Click OK. This step takes some time to execute.

15. The Physical tab shows the new floorplan with the drawn blockage and region. To verify
that the 1_cpu_sys block was placed inside 1 » region, select it from the Instance
list.
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Figure 4-6. New Floorplan With Drawn Blockage and Region

16. (optional) If you plan to continue with the next procedure, do not exit from the design
session.

Related Topics

Generating an Initial Floorplan

Constraining a Floorplan by Reading a DEF File

Constraining a Floorplan by Reading a DEF
File
To add physical constraints to the floorplan, another method is to read the fence and regions
from a DEF file.

Use fences to confine hierarchical modules by keeping them out of a certain region. Use regions
to group blocks together in a designated area.
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Constraining a Floorplan by Reading a DEF File

Prerequisites
e A generated design database (odb).
Procedure

1. Ifyou are continuing from “Constraining a Floorplan with User-Defined Blockages and
Regions” on page 60, go to the next step. Otherwise, do the following:

a. Invoke the Oasys-RTL GUI:

$SOASYS HOME/bin/ocasys -gui -log output/logs/floorplan.log

b. Open the synthesized and optimized Oasys-RTL database generated in Chapter 2,
“Design Synthesis™:

read_db output/odb/demo_chip.oasys_final.odb

2. Delete the physical data by entering the following command at the Oasys-RTL prompt
in the GUI:

delete_physical -all

3. Load the DEF file for placement by entering the following command at the Oasys-RTL
prompt:

read_def constraints/define_regions.def

This loads the floorplan with two regions defined in the DEF file for blocks 1_cpu_sys
and 1_usbf (Figure 4-7).
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Figure 4-7. Floorplan with Two Regions Defined in the DEF File

4. To complete the placement, enter the following command at the Oasys-RTL prompt:
optimize -place

5. Review the placement of the design. Notice that the 1 cpu sys and 1_usbf blocks are
placed in their assigned regions (Figure 4-8).

To verify this, multi-select the 1_cpu_sys and 1_usbf blocks in the Instance list by first

selecting the 1_cpu_sys block, then pressing Ctrl-Left-click and selecting the 1 usbf
block.
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Figure 4-8. Design with Blocks Place in Assigned Region

6. (optional) If you plan to continue with the next procedure, do not exit from the design
session.

Related Topics
Constraining a Floorplan with User-Defined Blockages and Regions

Generating an Initial Floorplan

Creating a Rectilinear Floorplan

It 1s possible to create floorplans with a rectilinear footprints by using a set of coordinates.

For many designs and SoCs, a rectilinear shape is required to optimize chip area and space.
Oasys-RTL floorplanning supports rectilinear shapes.
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Prerequisites

A generated design database (odb).

Procedure

1.

-
.

If you are continuing from “Constraining a Floorplan by Reading a DEF File” on
page 66, go to the next step. Otherwise, do the following:

a. Invoke the Oasys-RTL GUI:
$SOASYS HOME/bin/ocasys -gui -log output/logs/floorplan.log

b. Open the synthesized and optimized Oasys-RTL database generated in Chapter 2,
“Design Synthesis™:

read_db output/odb/demo_chip.<dft>_post_fix.odb
Load the rectilinear floorplan by entering the following at the Oasys-RTL prompt:
source scripts/rectilinear.tcl

This removes any existing physical design information and creates an L-shaped
floorplan area (Figure 4-9).

Figure 4-9. L-Shape Floorplan Area

To complete the placement, select Flow > Optimize and select the Place only box in the
Optimize dialog box. Click OK.

4. Review the placement of the design.

To display hierarchical view as shown in Figure 4-10, select View > Hierarchical View
from the main menu. The colors correspond to the hierarchy grouping in the RTL.
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Figure 4-10. Hierarchical View of the Design

5. Exit the Oasys-RTL tool.

Related Topics
Constraining a Floorplan by Reading a DEF File

Generating an Initial Floorplan
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